Problem with PID

I’m having issues with the PID. Everything is seems to be connected according to the provided schematics, and all components work, we’ve measured them. As you can see on the picture, the PID gets the correct temperature from the thermocouples, currently 33, and is set to heat until 200. However, it doesn’t signal to the SSR’s to power the band heaters.
We’ve measured it through, and the PID is powered and signaled properly, but it doesn’t give output signals at nr. 4 and 5 (and 3).

Does anyone have any idea what could be the problem, and how to fix it? I’m pretty sure it’s not a broken PID, because we have the same issue with all four of them (2x at extrusion and 2x at injection, no compression built yet). But I have no clue what could be another reason…

Don’t think that’s it, the problem seems to be ‘in’ the PID controller. It doesn’t give an output current on ports 4 and 5, which it should do to allow the SSR to work, which in turn puts the heaters to work. Does anyone know what’s actually going on inside a PID controller, and how this might be resolved?

BTW, I don’t know anything about electricity, so I might be totally wrong. But I do have and electrician with me here, and this is what he told me.

I have an issue with the compression oven’s temp control… I have none.

I set the temp for 250 deg celcius and, when it gets there, it keep heating … it doesn’t maintain a constant set temp. I changed the thermocouple… nope. Ssr’s Sticker heated and has a bubble so maybe it fried??? I’ll swap that next and see… last resort is to change pid … I had bought enough kits to make all 3 machines plus one spare. All wiring made by a certified electrician but as luck would have it I have access to an electrical engineer through one of my students👍😁😁 . He will look at the oven after the Christmas break.

@faro360,

Keep an eye on this topic then

Okay, cool. Looking forward to that post then.
I’ve left Senegal, so I’m not sure what the current state of the machines is. But I should be going back in a couple of months, so it would be useful to have your findings in that post by then. 🙂

@faro360, @jerzeek, @xxxolivierxxx

If your PID controller says REX-C100FK02-M*AN at the side and is RELAY type, then it is a bit crappy (but still works)

I had a couple of these and they need a special wiring. I’ll make a post soon about it.

@faro360
Wauw i would have never thought of that!
Always improvising in Africa 🙂

I had a very similar problem when I made my extruder and I found out that the solid state relays have polarity, so by just inverting both input cables everything started working. However, if you say that your machine worked fine at the electrician’s house, then you already know there’s nothing wrong with it 🙂

Thanks for the suggestion, @jerzeek! Yes we did, tried all kinds of variations 🙂

So now the electrician seems to have found a plausible cause. The current in the house might be too low and too unstable, which is causing the PID to not work properly. The current is at +/_170V while it should be 220V. He tested the PID at his own house and there it did work. So now we’ll buy a regulator and that should fix the problem.

Does that make sense to people who understand electrics? 🙂
Any other recommendations?

did you check the polarity of the signal wires? i know plus on the PID has to go to Plus on the SSR